Chapter 9 Applications: Data Exploration

This applications section covers five tasks. Tasks 1 and 2 present an overview of data exploration in ArcMap: you will perform “select feature by location” in Task 1 and “select feature by graphic” in Task 2. In Task 3, you will query a joint attribute table; examine the query results using a magnifier window; and bookmark the area with the query results. Task 4 covers relational database query. Task 5 combines spatial and attribute data queries. Task 6 deals with raster data query.

Task 1: Select Feature by Location 

What you need: idcities.shp, with 654 places in Idaho; and snowsite.shp, with 206 snow stations in Idaho and the surrounding states.

Task 1 lets you use the select feature by location method to select snow stations within 40 miles of Sun Valley, Idaho and plot the snow station data in charts.

1. Start ArcCatalog, and make connection to the Chapter 9 database. Launch ArcMap. Add idcities.shp and snowsite.shp to Layers. Right-click Layers and select Properties. Under the General tab, rename the data frame from Layers to Tasks 1&2 and choose Miles from the Display dropdown list. 

2. This step is to select Sun Valley from idcities. Choose Select By Attributes from the Selection menu. Select idcities from the Layer dropdown list and “Create a new selection” from the Method list. Then prepare a SQL statement in the expression box as: “CITY_NAME” = ‘Sun Valley’. (If Sun Valley does not appear in the values box, click on Complete List.) Click Apply. Sun Valley is now highlighted in the map. 

3. Choose Select By Location from the Selection menu. Do the following in the Select By Location dialog: choose “select features from” from the first dropdown list, check snowsite, choose “are within a distance of” from the second list, choose idcities from the third list, enter 40 (miles) for the distance to buffer, and click Apply. Snow courses that are within 40 miles of Sun Valley are highlighted in the map. 

4. Right-click snowsite and select Open Attribute Table. Click Selected to show only the 24 snow courses within 40 miles of Sun Valley. 

5. Now you will graph the elevation (ELEV) and maximum snow water equivalent (SWE_MAX) of the 24 snow courses. Click the Tools menu, point to Graphs, and select Create. In the first panel of Graph Wizard, click on the Graph type of Scatter and the upper left Graphic subtype. In the second panel, make sure that snowsite is the layer that contains data. Check ELEV, and uncheck all others, for the Y axis field. Check SWE_MAX for the X axis field. In the third panel, enter Elev-SweMax for the title, uncheck Show Legend, and click Finish. A scatter diagram showing a positive relationship between ELEV and SWE_MAX appears. 

Task 2: Select Feature by Graphics 

What you need: idcities.shp and snowsite.shp, same as Task 1.

Task 2 lets you use the select feature by graphics method to select snow stations within 40 miles of Sun Valley.

1. Make sure that the Tasks 1&2 data frame still contains idcities and snowsite in ArcMap. Choose Clear Selected Features from the Selection menu to clear features selected in Task 1. Choose Select By Attributes from the Selection menu. Select idcities from the Layer dropdown list and “Create a new selection” from the Method list. Then prepare a SQL statement in the expression box as: “CITY_NAME” = ‘Sun Valley’. (If Sun Valley does not appear in the values box, click on Complete List.) Click Apply. Sun Valley is now highlighted in the map. 

2. This step is to draw a circle around Sun Valley. Click the New Rectangle dropdown arrow on the Draw toolbar and select New Circle. Click Sun Valley in the map and drag the mouse pointer to draw a circle. (A radius reading in meters should appear in the lower left of the screen.) Right-click anywhere within the circle and select Properties. Under the Size and Position tab, first click the center Anchor Point and then enter 128720 meters for the Size Width. (A width of 128720 meters is the same as a diameter of 80 miles or a radius of 40 miles.) Click OK. If the circle you have drawn is not right, you can delete it and re-draw it. 

3. Now you will use the circle to select features in snowsite. Click the Selection menu and click Set Selectable Layers. Check snowsite, uncheck idcities, and close the dialog. Click the Selection menu and click Select by Graphics. Snow courses that are within 40 miles of Sun Valley are highlighted in the map. Open the attribute table of snowsite. Click Selected to show only the selected snow courses, which should be exactly the same as those in Task 1.
Task 3: Query Attribute Data from a Joint Table

What you need: wp.shp, a vegetation stand map; wpdata.dbf, a dBASE file containing stand data for wp.shp. 

As explained in the text, query or data selection is the most important element of data exploration. Data query can be approached from either attribute data or spatial data. Task 3 focuses on attribute data query.

1. Select Data Frame from the Insert menu in ArcMap. Rename the new data frame Task 3, and add wp.shp Task 3. Right-click wp and select Open Attribute Table. The field ID to the far right of the attribute table will be used in joining tables. Close the wp attribute table.

2. Click the Add Data button, navigate the Chapter 9 database, and add wpdata.dbf to Task 3. Right-click wpdata and select Open. Wpdata contains attributes such as Origin, As, and Elev for polygons in wp. The field ID will be used in joining tables. Close wpdata.

3. Right-click wp, point to Joins and Relates, and select Join. At top of the Join Data dialog, opt for joining attributes from a table. Then select ID in the first dropdown list, wpdata in the second list, and ID in the third list. Click OK to dismiss the dialog.

4. Wpdata is now joined to the wp attribute table. Right-click wp and select Open Attribute Table. The joined table has two sets of attributes, distinguished by the prefix. Attributes with the prefix of wp such as wp.ID are from the wp attribute table, and attributes with the prefix of wpdata such as wpdata.ID are from wpdata.

5. To perform query using the joined table, click the Options dropdown arrow and choose Select by Attributes. In the Select by Attributes dialog, make sure that the method is to create a new selection. Then prepare a SQL statement in the expression box that reads: “wpdata.ORIGIN” > 0 AND “wpdata.ORIGIN” <= 1900. Click Apply.

6. Click Selected at the bottom of the table so that only the selected records (175 out of 856) are shown. Polygons of the selected records are highlighted in the wp map. To narrow the selected records, click the Options dropdown arrow and choose Select by Attributes. In the Select by Attributes dialog, make sure that the method is to select from current selection. Then prepare a SQL statement in the expression box that reads: “wpdata.ELEV” <= 30. Click Apply. This selection results in 32 records (polygons) out of a total of 856. To take a closer look at the selected polygons in the map, click the Window menu and select Magnifier. When the magnifier window appears, click the window’s title bar and drag the window over the map to see a magnified view. 

7. Before moving to the next part of the task, select Clear Selected Features from the Selection menu to clear the selection.  

8. Click the Selection menu and click Select by Attributes. Enter the following SQL statement in the expression box: (“wpdata.ORIGIN” > 0 AND “wpdata.ORIGIN <= 1900) AND “wpdata.ELEV” > 40. (Notice that the first part of the expression about ORIGIN is enclosed in a pair of parentheses. You can either click () first or enter them manually.) Click Apply. Right-click wp and select Open Attribute Table. Click Selected at the bottom of the Attributes of wp table. Four records are selected. The selected polygons are near the top of the map. Use the Zoom In tool to zoom in the area around the selected polygons. You can bookmark the zoom-in area for future reference. Click the View menu, point to Bookmarks, and select Create. Enter protect for the Bookmark Name. To view the zoom-in area next time, click the View menu, point to Bookmarks, and select protect. 

Task 4: Query Attribute Data from a Relational Database 

What you need: mosoils.shp, a soil map; comp.dbf, forest.dbf, and plantnm.dbf, three dBASE files from the National Map Unit Interpretation Record (MUIR) database maintained by the Natural Resources Conservation Service (NRCS)

Task 4 lets you work with the MUIR database. By linking the tables in the database properly, you can explore many soil attributes in the database from any table. And, because the tables are linked to the soil map, you can also see where selected records are located.

1. Select Data Frame from the Insert menu in ArcMap. Rename the new data frame Task 4, and add mosoils.shp, comp.dbf, forest.dbf, and plantnm.dbf to Task 4. Mosoils is a soils shapefile. Comp, forest, and plantnm are dBASE files with soil attributes. 

2. First, relate mosoils to comp. Right-click mosoils in the Table of Contents, point to Joins and Relates, and click Relate. In the Relate dialog, select MUSYM in the first dropdown list, comp in the second list, and MUSYM in the third list, and enter soil_comp as the relate name. Click OK to dismiss the dialog.

3. Follow the same procedure as in step 2 to prepare two other relates: forest_comp, relating forest to comp by using MUID as the common field; and forest_plantnm, relating forest to plantnm by using PLANTSYM as the common field.

4. The four tables (the mosoils attribute table, comp, forest, and plantnm) are now related in pairs by three relates. Right-click comp and select Open. Click the Options dropdown arrow and choose Select by Attributes. In the next dialog, create a new selection by entering the following SQL statement in the expression box: “ANFLOOD” = ‘FREQ’ OR “ANFLOOD” = ‘OCCAS’. Click Apply. Click Selected at the bottom of the table so that only the selected records are shown.

5. To see which records in the mosoils attribute table are related to the selected records in comp, go through the following steps. Click the Options dropdown arrow in the comp table, point to Related Tables, and click soil_comp: mosoils. The Attributes of mosoils table appears with the related records. And the mosoils map shows where those selected records are located.

6. You can follow the same procedure as in the previous step to see which records in forest are related to those polygons that have frequent or occasional annual flooding.

7. Because no relate exists between comp and plantnm, you cannot open selected records in plantnm directly from comp. Instead, you can open selected records in plantnm from the Selected Attributes of forest table by using the related tables of forest_plantnm: plantnm. 

Task 5: Combine Spatial and Attribute Data Query

What you need: thermal.shp, a coverage with 899 thermal wells and springs; idroads.shp, showing major roads in Idaho

Task 5 assumes that you are asked by a company to locate potential sites for a hot spring resort in Idaho. You are given two criteria for selecting potential sites:

· The hot spring must be within 2 miles of a major road.

· The temperature of the hot spring must be greater than 600C.

The field type in thermal.shp uses s to denote springs and w to denote wells. The field temp shows the water temperature in 0C.

1. Select Data Frame from the Insert menu in ArcMap. Add thermal and idroads to the new data frame. Right-click the new data frame and select Properties. Under the General tab, rename the data frame Task 5 and choose Miles from the Display dropdown list. 

2. First select thermal springs and wells that are within 2 miles of major roads in Idaho. Choose Select By Location from the Selection menu. Do the following in the Select By Location dialog: choose “select features from” from the first dropdown list, check thermal, select “are within a distance of” from the second list, select idroads from the third list, and enter 2 (miles) for the distance to buffer. Click Apply. Thermal springs and wells that are within 2 miles of roads are highlighted in the map. 

3. Next, narrow the selection of map features by using the second criterion. Choose Select By Attributes from the Selection menu. Select thermal from the Layer dropdown list and “Select from current selection” from the Method list. Then prepare a SQL statement in the expression box as: “TYPE” = ‘s’ AND “TEMP” > 60. Click Apply.

4. Right-click thermal and open its attribute table. Click Selected at the bottom of the attribute table so that only the selected records are shown. The selected records all have Type of s and Temp above 60.

5. Map tips are useful for examining the water temperature of the selected hot springs. Right-click thermal in the Table of Contents and select Properties. Under the Display tab, check the box to Show Map Tips (uses primary display field). Under the Fields tab, select TEMP from the Primary display field dropdown list. Click OK to dismiss the Properties dialog. Click the Select Elements button. Move the mouse pointer to a highlighted hot spring, and a map tip display the water temperature of the spring. 

Task 6: Raster Data Query

What you need: slope_gd, a slope grid; and aspect_gd, an aspect grid

Task 6 shows you different methods for querying a single grid or multiple grids (two for Task 6).

1. Select Data Frame from the Insert menu in ArcMap. Rename the new data frame Task 6, and add slope_gd and aspect_gd to Task 6. 

2. Select Extension from the Tools menu and make sure that Spatial Analyst is checked. Click the View menu, point to Toolbars, and check Spatial Analyst. The Spatial Analyst toolbar is added. Select Raster Calculator from the Spatial Analyst toolbar. In the Raster Calculator dialog, prepare the following statement in the expression box: [slope_gd] = 2. (The = sign appears as == in the expression box.) Click Evaluate. The layer Calculation is added to the Table of Contents. Cells with the value of 1 are areas with slopes between 10 and 20 degrees.

3. Select Raster Calculator from the Spatial Analyst toolbar, and prepare the following statement in the expression box: [slope_gd] = 2 AND [aspect_gd] = 4. (And is shown & in the expression box.) Click Evaluate. Cells with the value of 1 in Calculation2 are areas with slopes between 10 and 20 degrees and the south aspect. 

