Chapter 15 Applications: Regions

This applications section covers six tasks. Task 1 uses ArcView 8.1 to display and query regions. Task 2 uses ArcInfo 8.1 to create regions from existing polygons. The remaining four tasks use ArcInfo Workstation. Tasks 3 and 4 focus on creating regions, and Tasks 5 and 6 tabulate region overlaps and perform regions-based overlay respectively. 

Task 1: Display and Query Regions in ArcMap

What you need: a regions-based coverage called intcov.

The integrated polygon coverge intcov has six region subclasses: land from a land use coverage, soil from a soils coverage, stream from a stream buffer coverage, sewer from a sewer buffer coverage, and potsites and finalsites from results of regions-based queries. The purpose of this task is to display and query regions in ArcMap.

1. Start ArcCatalog, and make connection to the Chapter 15 database. Launch ArcMap, and rename Layers Task 1. Click the Add Data button. Navigate to the Chapter 15 database. Double-click on intcov. Ten data sets appear. Select polygon, region.finalsites, region.land, region.potsites, region.sewer, region.soil, and region.stream, and add them to Task 1. Examine the integrated polygon coverage and each of the six region subclasses.

2. Select Open Attribute Table from the context menu of intcov region.soil. Click the Options dropdown arrow and choose Select by Attributes. Enter the following SQL statement in the expression box: “SUIT” = 2. Click Apply. All polygons in region.soil that have the suit value of 2 are highlighted. A region subclass behaves like a regular layer for data display and query. 

3. Select Open Attribute Table from the context menu of intcov region.potsites. Click the Options dropdown arrow and choose Select by Attributes. Enter the following SQL statement in the expression box: “AREA” > 2000. Click Apply. Seven out of 10 polygons in region.potsites are selected. This selection can be saved into a new shapefile. Right-click intcov region.potsites, point to Data, and select Export Data. Specify sel_sites.shp as the output shapefile in the Export Data dialog. Sel_sites contains the same polygons as intcov region.finalsites. 

Task 2: Create Regions from Existing Polygons in ArcMap

What you need: landuse, a coverage with en empty region subclass called urban.
If you are using ArcInfo 8.1, you can use ArcMap to create regions from existing polygons and stored them in a region subclass in Task 2. The region subclass, however, must be created first as an empty subclass in ArcInfo Workstation using the ArcEdit command of CREATEFEATURE:

Arcedit: mapextent landuse

Arcedit: editcov landuse

Arcedit: createfeature region.urban

Arcedit: quit  /*save changes

1. Select Data Frame from the Insert menu in ArcMap. Rename the new data frame Task 2. Click the Add Data button. Navigate to the Chapter 15 database. Double-click landuse. Select polygon and region.urban and add them to Task 2. Landuse region.urban currently has no features. 

2. The first step is select existing polygons to be grouped into the urban region subclass. Select Open Attribute Table from the context menu of landuse polygon. Click the Options dropdown arrow and choose Select by Attributes. Enter the following SQL statement in the expression box: “LUCODE” = 100. Click Apply. The selected records are highlighted in both the attribute table and the map. 

3. This step is to group urban polygons into a region subclass. Click the Editor Toolbox. Select Starting Editing from the Editor dropdown list. Make sure that the Task is to Create New Feature and the Target is landuse region.urban. Click the Editor dropdown arrow, and select Union. The seven urban polygons are now components of the region subclass urban. Select Open Attribute Table from the context menu of landuse region.urban. A (region) record should appear in the table. Select Stop Editing from the Editor dropdown list. Save the edits. 

Task 3: Create Regions from Existing Polygons in ArcInfo Workstation
What you need: landuse, same as Task 2.

This task asks you to create a region from polygons that have the lucode value of 700 in the coverage landuse. Go to ArcEdit and set up the editing environment:

Arcedit: display 9999

Arcedit: mapextent landuse

Arcedit: editcov landuse

Arcedit: drawenv poly label  

Arcedit: draw  /* This will draw polygons and labels of landuse

Arcedit: editfeature label

Arcedit: select lucode = 700  /* Select labels that have lucode = 700

Arcedit: drawselect  /* This highlights three selected labels 

Arcedit: editfeature polygon  /* Change the edit feature to polygons

Arcedit: select many  /* Click the three labels previously highlighted and press 9 to exit

Arcedit: makeregion marsh  /* Create a region called marsh from the selected polygons

Arcedit: quit  /* Save the changes made in the session

Arc: describe landuse 

The DESCRIBE command provides a description of the coverage landuse and its content. The feature class should include regions, and the subclass should list marsh (along with urban from Task 2). Type ‘list landuse.patmarsh’ to view the marsh subclass' PAT. Only one record is listed in the PAT because three polygons are grouped into a single region using the noncontiguous option.

Task 4: Create Regions by Using Regions-based Commands

What you need: a polygon coverage called fire.

The coverage fire shows past fires in a national forest. Three attribute items (fire1, fire2, and fire3) record up to three fire events in a given polygon. For example, a polygon with recorded fires in 1909, 1923, and 1970 has the values of 1970, 1923, and 1909 under fire1, fire2, and fire3 respectively. The purpose of this task is to use the command regiondissolve to create a region subclass.

Arc: regiondissolve

Usage: regiondissolve <in_cover> {out_cover} <out_sublcass> <dissolve_item | 

#ALL> {POLY | REGION.Subclass}

Arc: regiondissolve fire # fire2 fire2  

regiondissolve uses the dissolve item fire2 to create a region subclass called fire2 in the coverage fire. You can use ArcTools, a graphical user interface to ARC/INFO, to display the region subclass fire2:

1. Type arctools at the Arc prompt. Select Map Tools from the Arctools menu. Then select New from the View menu in the Map Tools dialog. 

2. In the Add New Theme dialog, select Coverage for Categories and Region for Theme Classes.

3. In the Region Theme Properties dialog, enter fire2 as the Identifier, fire as the Data Source, and fire2 as the Region. Select red as the symbol to draw regions. Click Preview to view the region subclass of fire2.

Now, go to Tables. Use the dir command in Tables to list all the INFO files in your workspace. You should see fire.pat and fire.patfire2.

Tables: select fire.patfire2  /* select the PAT of the region subclass fire2

Tables: list  /* list records in the PAT

You can remove the fire2 region subclass from the fire coverage by using the command dropfeatures:

Arc: dropfeatures

Usage: DROPFEATURES <cover> <feature_class> {ATTRIBUTE | GEOMETRY}

Arc: dropfeatures fire region.fire2

regionquery is another regions-based command that can create regions. regionquery uses logical expressions to select polygons to be grouped into regions. In the following, regionquery creates nested regions of fire1, fire12, and fire123 from the coverage fire. The fire1 region layer represents areas burned once, fire12 burned twice, and fire123 burned three times. The three layers are superimposed on one another, forming a set of nested regions.

Arc: regionquery

Usage: REGIONQUERY <in_cover> {out_cover} <out_subclass> {selection_file}

{NONCONTIGUOUS | CONTIGUOUS} {out_item . . . out_item}

Arc: regionquery fire # fire1 # # fire1

  >: reselect fire1 > 0  

  >:

Arc: regionquery fire # fire12 # # fire1 fire2

  >: reselect fire1 > 0 and fire2 > 0

  >:

Arc: regionquery fire # fire123 # # fire1 fire2 fire3

  >: reselect fire1 > 0 and fire2 > 0 and fire3 > 0

  >:

Now display the nested regions of fire1, fire12, and fire123 using ArcTools:

1. Type arctools at the Arc prompt. Select Map Tools from the ArcTools menu. Then select New from the View menu in the Map Tools dialog. 

2. Select Coverage for Categories and Region for Theme Classes in the Add New Theme dialog.

3. First, set up the draw environment for fire1. In the Region Theme Properties dialog, enter fire1 as the Identifier, fire as the Data Source, and fire1 as the Region. Select red as the symbol to draw regions, and click OK.

4. Repeat Steps 2 and 3 to set up the draw environment for fire12. Enter fire12 as the Identifier, fire as the Data Source, and fire12 as the Region in the Region Theme Properties dialog. Select green for the Symbol, and click OK.

5. Repeat Steps 2 and 3 to set up the draw environment for fire123. Enter fire123 as the Identifier, fire as the Data Source, and fire123 as the Region in the Region Theme Properties dialog. Select blue for the Symbol, and click OK.

6. Fire1, fire12, and fire123 are now listed under Themes in the Theme Manager dialog. Use the arrow to move the three region layers to the Draw list. Then click on the Draw button to draw the region layers in three different colors.

You can list the attributes contained in the PAT of each region subclass in either Arc or Tables.

Arc: list fire.patfire12

Arc: list fire.patfire123

Task 5: Tabulate Region Overlaps

What you need: a polygon coverage called sfire.

The ARC command regionxarea runs an AML macro to tabulate all possible region overlaps and their areas and percentage areas. The result is saved into an INFO file. Depending on the number of region subclasses and the number of regions in each subclass, the INFO file can be massive. For this task, you will use a small coverage called sfire so that you can better understand how regionxarea works.

1. Similar to Task 3, use regionquery to create the region layers of fire1, fire12, and fire123 from the coverage sfire.

2. Use ArcTools to display the nested region subclasses in sfire.

3. Now, run regionxarea in Arc. Ignore messages from the execution of regionxarea.

Arc: regionxarea

Usage: regionxarea <in_cover> <out_info_file> {$ALL | subclass . . . subclass}

Arc: regionxarea sfire sfire.dat

4. List the INFO file created by regionxarea.

Arc: list sfire.dat

Each record in sfire.dat represents an overlap of regions. Subclass1 and subclass2 are the two region subclasses in the overlap. Subclass1# and subclass2# list the regions in the overlap. Area is the size of the overlap, and percent shows the area percentage of subclass1# overlapping with subclass2#. As examples, the first record in sfire.dat shows that 43.15% of fire1 is overlapping with the first region of fire12 and the second record shows that 18.48% of fire1 is overlapping with the second region of fire12.  

Task 6: Perform Regions-based Overlay 

What you need: coverages of landuse, soils, strmbuf, and sewerbuf.

As described in this chapter, AREAQUERY can perform both map overlay and data query in a single operation. AREAQUERY is an alternative to the traditional overlay method for GIS analysis. This task simulates a suitability analysis with the following selection criteria:

· Preferred land use is brushland (lucode = 300 in landuse)

· Choose soil types suitable for development (suit >= 2 in soils)

· Site must be within 300 meters of existing sewer lines (sewerbuf)

· Site must be beyond 20 meters of existing streams (strmbuf)

· Site must contain an area at least 2000 meters square

Arc: areaquery 

Usage: areaquery <out_cover> <out_subclass> {tolerance}

{NONCONTIGUOUS|CONTIGUOUS} {out_item…out_item}

Arc: areaquery allcov potsites # contiguous  /* initiate AREAQUERY

A dialog command, areaquery first asks for input coverages and their region subclass names.

[Enter the 1st coverage:] landuse land  /* land is the subclass name for landuse

[Enter the 2nd coverage:] soils soil  /* soil is the subclass name for soils

[Enter the 3rd coverage:] sewerbuf sewer  /*sewer is the subclass name for sewerbuf

[Enter the 4th coverage:] strmbuf stream  /*stream is the subclass name for strmbuf

[Enter the 5th coverage:] end

AREAQUERY then asks for a logical expression. Each operand in the logical expression consists of two parts: the first part refers to the region subclass, and the second part refers to the item in the region subclass. The logical expression can include the Boolean connectors of AND, OR, XOR, and NOT.

>: resel land.lucode = 300 and soil.suit >= 2 and $sewer and not $stream

>: [hit return]

Arc: list allcov.patpotsites

The output from AREAQUERY is saved into the region subclass potsites, which includes sites that satisfies the first four criteria. To complete the task, use REGIONQUERY to select sites that are larger than 2000 m2.

Arc: regionquery allcov # finalsites # contiguous

>: resel potsites.area > 2000

>: [hit return]

